Commit c56bd49c authored by Matteo De Carlo's avatar Matteo De Carlo

updated build tools and dependencies

- updated kotlin to 1.2.71
- updated gradle to 4.6
- updated android-gradle to 3.2.1
- updated android build tools to 28.0.3
- updated android support constraint-layout to 1.1.3
parent 95ed3015
......@@ -10,7 +10,7 @@ android {
}
}
compileSdkVersion 27
buildToolsVersion "27.0.3"
buildToolsVersion "28.0.3"
defaultConfig {
applicationId "org.covolunablu.marswallpaper"
minSdkVersion 15
......@@ -42,7 +42,7 @@ dependencies {
implementation fileTree(include: ['*.jar'], dir: 'libs')
implementation "org.jetbrains.kotlin:kotlin-stdlib-jre7:$kotlin_version"
implementation 'com.android.support:appcompat-v7:27.1.1'
implementation 'com.android.support.constraint:constraint-layout:1.1.0'
implementation 'com.android.support.constraint:constraint-layout:1.1.3'
implementation 'org.sufficientlysecure:donations:2.6'
testImplementation 'junit:junit:4.12'
androidTestImplementation 'com.android.support.test:runner:1.0.2'
......
// Top-level build file where you can add configuration options common to all sub-projects/modules.
buildscript {
ext.kotlin_version = '1.2.30'
ext.kotlin_version = '1.2.71'
repositories {
google()
jcenter()
}
dependencies {
classpath 'com.android.tools.build:gradle:3.1.2'
classpath 'com.android.tools.build:gradle:3.2.1'
classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin_version"
// NOTE: Do not place your application dependencies here; they belong
......
#Wed May 16 16:12:46 CEST 2018
#Thu Nov 29 13:58:34 CET 2018
distributionBase=GRADLE_USER_HOME
distributionPath=wrapper/dists
zipStoreBase=GRADLE_USER_HOME
zipStorePath=wrapper/dists
distributionUrl=https\://services.gradle.org/distributions/gradle-4.4-all.zip
distributionUrl=https\://services.gradle.org/distributions/gradle-4.6-all.zip
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment